CUPS Samba and Dymo Printing[SOLVED]

I am currently setting up a new server and have run into a wierd problem with printing labels.  The label printer is configured using samba (its on a windows host)

The Dymo printer  has lables that a designed to be printed in landscape with using a PLUS90 rotation.  

The  PPD drivers from dymo for the 450 turbo actually default to a minus90.  So I decompiled the PPDs rewrote them and selected the printer to use that ppd.  However it doesnt actually actually change the rotation.  So what I did was change the printer settings in Open to Potrait as well as redesigning the print output in the jrxml to be potrait so that any rotation is actually done by the drivers.......but it still rotates it minus90.  

At this point I can only assume its actually the cups-samba interaction that is rotating the postscript file 

Anyone got any advice for this scenario.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: CUPS Samba and Dymo Printing

There's no guarantees that the orientation specified via the Document Template will be honoured by the printer.

Have you tried changing the page width and page height within JasperStudio to make the report design landscape as per http://community.jaspersoft.com/questions/543563/page-orientation

Re: CUPS Samba and Dymo Printing

I've had this problem before. You need to set the default setting for that printer manually in your lpoptions file on the cups server. 

I'm not sure where it would be in samba but in ubuntu it's​

/etc/cups/lpoptions

And this is the option I use:

Dest DYMO_DYMO_LabelWriter_Twin_Turbo orientation-requested=6

I'm not sure at what orientation I have my template so you may need to adjust the number

Re: CUPS Samba and Dymo Printing

Thanks Matt 

The solution to this ended up being to run

sudo -su <tomcatuser> loptions -d <printername> -o orientation-requested=6
​
The options are actually set per user now - to set default you run as root, but I am thinking that because tomcat runs as tomcat7 user you want to set it using that user....interesting because tomcat7 (atleast in my case has no home) - it is set to have a nologin I am not entirely sure were it is pulling the settings from ...so I set it both as root and theuser.
Regards
 
Ben 
OpenVPMS Installer and Helper 
Ph: +61423044823 
Email: benjicharlton[at]gmail[dot]com

Re: CUPS Samba and Dymo Printing[SOLVED]

I just had the same problem. The fix is to run (for our 3 Dymo LabelWriter Duo label printers):

sudo lpoptions -p LABEL-PS121 -o orientation-requested=6
sudo lpoptions -p LABEL-R2 -o orientation-requested=6
sudo lpoptions -p LABEL-S2 -o orientation-requested=6

This sets the following into /etc/cups/lpoptions

Dest LABEL-PS121 orientation-requested=6
Dest LABEL-R2 orientation-requested=6
Dest LABEL-S2 orientation-requested=6

and according to man lpoptions this sets the system wide defaults (so no need to set separately for the tomcat7 user).

The "orientation-requested=6" works with the template orientation set to Landscape.

Regards, Tim G

Syndicate content