Locked documents


We have some patient letters that we do not use very often.

I have tried to use one today and after making changes with external edit I then get a message that the document is locked.

I have looked under system and it is not there to release.

I have created a new template and document/edited and re attached the document.

I am not sure if this could have happened with an upgrade that has changed old templates etc.

Would anyone have any offerings?

Thanks in advance,


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Re: Locked documents

Does the document name have any quotes in it?
If so, you may be seeing OVPMS-2220 which was fixed for OpenVPMS 2.1.2

Re: Locked documents

Ok so I might need more help :)


I am not sure about the quotes side of things

The file is named  -   PPVS Dental and Surgery After Care 11052016

And a lot of other names as I have tried to resave it.

This is the document that I browse and attach.

Happy to get help if that is needed

Re: Locked documents

What versions of OpenVPMS and OpenOffice are you using?

For OpenOffice, this is the one on your PC used to edit documents; you can find the version under Help - About.

Re: Locked documents

Office 4 .1 .5

Open VPMS  1.9.3





Re: Locked documents

I cannot reproduce this in OpenVPMS 2.1.2 with OpenOffice 4.1.5.

Re: Locked documents

Ok so what do I do next - I believe it worked in previous versions



Re: Locked documents

  1. Do you have problems using External Edit with other documents?
  2. What is the exact error message you are seeing?

Re: Locked documents

I feel there was a change after an upgrade.

We have many letters that we use and most are ok.

There is a random every so often and I think it may link back to our prev program.

I have attached the error messages that I am getting


Capture Open locked error saving.PNG 9 KB
Capture Open locked error.PNG 10.44 KB

Re: Locked documents

The first error 'Error saving the document... Obect not accessible. The object cannot be accessed due to insufficient user rights' I haven't seen before.

  1. Does this happen for all users, or a particular user?
  2. What steps did you do to trigger the error?

Most of the google results seem to indicate that this occurs when trying to save an OpenOffice file to a network share.

The second error, 'Document file ... is locked for editing by: bob' I would expect to see you were editing a file that was already being edited by user bob.

You should be able to verify this by going to Administration - System - Document Locks. You may need to click Find to refresh the view.




Re: Locked documents

The error saving was as I canceled out at the end and I think all uses - we only have 2 - it was bob today

We attach a letter

Press external edit

make changes

hit save icon

get the locked message

hit cancel

get the error saving message

Re: Locked documents

The only time you will see a 'Document file ... is locked for editing by: someuser' is if that user has edited the document, and acquired a lock.

In OpenVPMS 1.9.3, locks should be released when the user finishes editing it. If that is not the case, and you can't see any lock in Administration - System - Document Locks, you may need to restart Tomcat.

In OpenVPMS 2.1.2, lock management was improved, so I would not expect you to have any issues.

Re: Locked documents

Is it possible to create another document to replace the "locked" one?

Re: Locked documents

No. If you cannot see any lock in Administration - System - Document Locks, the only other option is to restart Tomcat.

I strongly recommend upgrading to the 2.1.2, as this improves lock management.

Syndicate content