OpenVPMS can be installed on either a unix system (most commonly a Ubuntu* server), or a Windows system.  For Windows, for small practices you can install on a desktop or laptop running Windows 7, 8 or 10; for larger practices it may be better to use a Windows Server operating system.

*NOTE: OpenVPMS requires MySQL 5.5, which is included in Ubuntu 14.04. Later releases include MySQL 5.6 or MySQL 5.7 which are only supported via configuration changes.

32 or 64 bit version? Both Java and MySQL are available in 32 and 64 bit versions. For larger systems (where you will want to run MySQL and Tomcat with large memory allocations) you should use the 64 bit versions. Otherwise the 32 bit versions are adequate.

Server Software

On Windows, the MySQL installer may require that the Microsoft .Net Framework 4 be installed. This is available from:
http://www.microsoft.com/en-au/download/details.aspx?id=17851
 

NOTE: if you are upgrading from an earlier MySQL release, see the relevant MySQL manual for migrating the MySQL data e.g.:

MySQL:

  • should be on the same host as Tomcat
  • should accept connections on port 3306
  • include the following lines in my.ini
    max_allowed_packet=16M
    innodb_file_per_table

 

    This may be included in the MySQL server installation.

Workstation Software

If you wish to use the External Edit facility then the following software is required on all workstations that will edit documents in OpenVPMS:

See http://www.openoffice.org/download/

Optional Software

Syndicate content